HTML5网页设计

jQuery

jQuery1.9判断是否ie6

时间:2014-09-03 18:45来自:未知作者:user点击:
jquery1.9如何判断IE6呢?最近把jquery从1.4.4版本升级到1.9后来发现蛮多问题的。

jquery1.9如何判断IE6呢?最近把jquery从1.4.4版本升级到1.9后来发现蛮多问题的。 在1.4版本里面我们是这样判断IE6的

var isIe6=false;
if($.browser.msie && parseInt($.browser.version)==6){
    isIe6=true;
}

在1.9里面却是失效了!

jquery1.9已经除移了$.browser 和 $.browser.version而代之的是 $.support

在这边共享一段兼容1.4和1.9版本的

var isIe6 = false;
if (/msie/.test(navigator.userAgent.toLowerCase())) {
    if (jQuery.browser && jQuery.browser.version && jQuery.browser.version == '6.0') {
        isIe6 = true
    } else if (!$.support.leadingWhitespace) {
        isIe6 = true;
    }
}

当前文章地址:http://www.shejicool.com/web/jquery/483.html

阅完本篇文章?您还可以: 收藏本文 文章挑错 朋友推荐